Affected: Zendesk Integration
Symptoms
The following error appears when navigating in Zendesk:
⚠️ LaunchDarkly user key not found
Organization field key
"[field key]" not found on [organization name]
Example:
Cause
This error occurs if you have checked the LaunchDarkly user key is an Organization field
on the integration configuration page but did not populate the organization field on the organization's tab in Zendesk with the key for the organization.
Example:
Investigation
-
Check to ensure you have followed the instructions in our Zendesk help documentation to configure the Zendesk custom Organization Field: Zendesk
-
Confirm that the integration is set up to intentionally display LaunchDarkly flags by the
organization
level and not theuser
level.
Solution
-
Obtain the target organization key by navigating to your LaunchDarkly account and choosing the Project & Environment configured for the integration from the environment picker.
-
Select the Users dashboard tab and locate the key for your organization in the Key column.