Affected: All SDKs
Symptoms
Percentage rollout appears uneven when compared to data shown in Insights.
Cause
This could be due to any of the following:
-
Missing attribute,
null
ornone
value set for the context attribute that is being used for percentage rollout. -
When the context objects share the same key or attribute value, it can result in the context yielding the same variation.
-
Context has already met the condition of an earlier rule within the feature flag, resulting in not being served the percentage rollout rule. This can impact the results displayed in the flag's Insights tab.
Solution
The data in the Insights tab are generated on a per-flag evaluation basis, not a per-context instance basis. For example, if the same context instance is evaluated 20 times, the flag evaluations graph records and displays all 20 evaluations.
If you are still experiencing issues with percentage rollout results, consider the following:
-
If you are using an attribute other than the
key
of the context, make sure it is present in the context object in your code and has a valid value for identifying the object for percentage rollout purposes. -
Ensure that the key/attribute you have selected for percentage rollout is statistically valid, as it can affect the accuracy of results. For example, if you use a key that is not uniformly distributed among your user/context base, the results will not be representative of the entire population.