Affected: Server-side SDKs
Symptoms
- Users receive the correct and expected evaluations but they do not appear in the dashboard.
- The insights for the flag(s) are also not being updated.
Cause
This can be explained by the SDK behavior. It queues up an analytic event containing the user data and sends it back to LaunchDarkly. The events are automatically flushed every 5 seconds. The method is in all LaunchDarkly SDKs, but the behavior may be different depending on the SDK.
For example, a short-lived process – such as a test script or program – could be closing the SDK before it has a chance to flush events.
Solution
Typically, this issue occurs in early development, and once customers realize the way events work, they realize that in a long-lived application, the event buffering behavior is not a problem.
If your application is short-lived and cannot rely on the event buffer, call flush()
to manually flush the event buffer. Refer to the documentationflush()
in the appropriate SDK.
Note: You should not call flush()
in a production app if it stays active long enough for the events buffer to flush on its own. Reference the SDK documentation for specifics; this may vary depending on the SDK.
If you find that you need to call flush for events to be sent, contact support for further assistance. Provide a description of your architecture, such as whether you are using containers or a forking system.