Affected: All SDKs
Symptoms
On flag creation, the following error appears:
A flag already exists with this key. Choose a different key.
Cause
A flag with this key already exists, so creating a new flag is blocked.
Solution
If you are receiving this error but cannot find a flag with the same key in your list of flags, it’s most likely because it has been archived.
Even when searching for the flags key, it won’t appear unless you utilize a filter to specify archived flags. To learn how to view archived flags, read: View and restore flags